Internal Sequencer Mode Omitting 1st-Step

Share your experience, tips & tricks, show off your music. Wishes, ideas and feature suggestions
Post Reply
a2n3d7y
Posts: 8
Joined: Wed Jan 30, 2008 7:23 am
Contact:

Internal Sequencer Mode Omitting 1st-Step

Post by a2n3d7y » Wed Mar 19, 2008 8:06 am

I quite enjoy using the internal sequencer mode to make chains of random sequences, but I've found a problem and am wondering if I'm alone in this.

Step-1 of a newly triggered pattern is omitted.

It's that simple.

Been reading the manual and trying different NOTE-OFF-CLEAR and SELF-RESET settings.

If said pattern is being repeated than step-1 is NOT-omitted.

Is this behavior normal?

Other than that I absolutely adore Phoscyon.

User avatar
Sebastian@d16
Posts: 1524
Joined: Tue Nov 07, 2006 9:20 pm
Location: Katowice/Poland

Post by Sebastian@d16 » Wed Mar 19, 2008 1:26 pm

Hey,

We are aware of such behavior and it's not "normal", it's a bug needs to be fixed. It's on our ToDo list.

Best regards,
Sebastian

a2n3d7y
Posts: 8
Joined: Wed Jan 30, 2008 7:23 am
Contact:

Post by a2n3d7y » Wed Mar 19, 2008 9:50 pm

Ok. Will be looking forward to the next update. :)
Thanks for the quick response.

Planning on purchasing the Devestor soon!

a2n3d7y
Posts: 8
Joined: Wed Jan 30, 2008 7:23 am
Contact:

Post by a2n3d7y » Tue Mar 25, 2008 11:15 pm

Interesting.
Check out this thread...
" [fixed] First Notes Of VSTi Plugins in Energy XT as VST"
http://www.renoise.com/board/index.php?showtopic=15720

And by the way Renoise is my host.

a2n3d7y
Posts: 8
Joined: Wed Jan 30, 2008 7:23 am
Contact:

Post by a2n3d7y » Wed Mar 26, 2008 7:20 am

Hey Sebastian@d16,
Just to let you know, Phoscyon works great in FL8.
I was using Renoise when I discovered the problem, which begs the question:
Is there a problem with Renoise, or is there a problem with Phoscyon?
(you don't have to answer that question)

User avatar
Sebastian@d16
Posts: 1524
Joined: Tue Nov 07, 2006 9:20 pm
Location: Katowice/Poland

Post by Sebastian@d16 » Wed Mar 26, 2008 12:19 pm

Hi,

I'm speaking about the issue with ommiting the first note in sequence (internal) when You press start button and the sequence is played for the first time, and further successing repetitions are played correctly. I noticed it with several hosts. Different hosts have different approach to synchronization. Patterns are triggered by midi note on code, but to keep the tempo host needs to send to plug-in transport change code (start), this thing sometimes arrives later than midi note on (dependly on host You're running on).

ATM the best synchronization routine is implemented in Nepheton, and soon all our machines are supposed to have such.

Best regards,
Sebastian

User avatar
Sebastian@d16
Posts: 1524
Joined: Tue Nov 07, 2006 9:20 pm
Location: Katowice/Poland

Post by Sebastian@d16 » Wed Mar 26, 2008 12:40 pm

One thing,

The bad thing is that there's no specification of VST host, VST plug-ins only. And such misunderstandings between host's developers and plug-in's developers will remain.

Best regards,
Sebastian

a2n3d7y
Posts: 8
Joined: Wed Jan 30, 2008 7:23 am
Contact:

FIXED

Post by a2n3d7y » Mon Sep 15, 2008 1:38 am

This issue has been fixed in Renoise2.0 Beta1.



:D

User avatar
Sebastian@d16
Posts: 1524
Joined: Tue Nov 07, 2006 9:20 pm
Location: Katowice/Poland

Post by Sebastian@d16 » Tue Sep 16, 2008 10:33 am

Hey,

Excellent news. I've just noticed that Renoise team is preparing major update :D

Best regards,
Sebastian

Kipster
Posts: 4
Joined: Mon Nov 10, 2008 9:36 pm

Post by Kipster » Mon Jan 12, 2009 5:32 pm

I'm using Cubase SE3 and have the same problem. Would love to be using the internal sequencer but am stuck on programming it into Cubase at the mo.

Any news on when this might be fixed in Phosycon? :)

Cheers

User avatar
Sebastian@d16
Posts: 1524
Joined: Tue Nov 07, 2006 9:20 pm
Location: Katowice/Poland

Post by Sebastian@d16 » Tue Jan 13, 2009 11:48 am

Hi,

Will be released together with Phoscyon AU update.

Best regards,
Sebastian

Kipster
Posts: 4
Joined: Mon Nov 10, 2008 9:36 pm

Post by Kipster » Tue Jan 13, 2009 1:53 pm

Happy days :)

Post Reply