Updated to OSX 10.5.6 -> All silverline plugin popup menu

If you need to write about anything else please do it here...
Post Reply
ostiknostis
Posts: 57
Joined: Fri May 30, 2008 1:42 pm

Updated to OSX 10.5.6 -> All silverline plugin popup menu

Post by ostiknostis » Sat Jan 10, 2009 9:59 pm

Disappeared! Booted from the OSX DVD and repaired permissions, but didn't help. So now I cannot access the preset browsers / options in any of the silverline plugs.. Both versions of the plugs (VST & AU) are affected by this..

I will attempt a more detailed debug of the situation later on, will edit my findings into this thread..

Once again I forgot the golden rule - "Never touch a running system" :(

EDIT: Problem solved!! It seems that the silver line menus only disappear when Ableton Live (at least version 7.0.10, will check 7.0.12 & 7.0.14 soon) is used in fullscreen mode. So this has something to do with OSX 10.5.6 and live's fullscreen mode (my theory of it anyway)

I'll check now to see if newer versions of Live exhibit the same issue..

EDIT2: The same issue occurs in Live 7.0.12 as well..
EDIT3: And issue still persists in Live 7.0.14, which I just installed into my system.

I don't know if future update from Apple will fix this, or a future update from Ableton. It also could be that this issue will not manifest in everyone's environment.. But anyway, if it does happen to you, just switch back to normal windowed mode in Live and the menus work again.

And yes, I checked my other plugins.. popup menus work normally in those, so this seems to limit the scope of the bug only to the silverline plugs.

One more thing I noticed - all the D16 factory presets disappeared from live's internal preset view? (they still work normally when accessed through the plugin GUI's though so no biggie - but might give more clues on what's going on..)

EDIT4: Sheesh.. It seems that I lost all my AU presets from all my plugins, not just from D16 plugs! Gotta love Apple for releasing an update like this...

User avatar
Sebastian@d16
Posts: 1524
Joined: Tue Nov 07, 2006 9:20 pm
Location: Katowice/Poland

Post by Sebastian@d16 » Mon Jan 12, 2009 12:08 pm

Hi,

We'll check this, because partially could be problem with framework we use to make menus and popup windows. When You start Ableton Live in fullscreen mode probably Live sets the highest priority for its window and when You try to pull down a menu or show a preset browser, it's just an ordinary popup window which is most likely shown, but behind a Live window. I guess that's the problem with new MacOS+Framework+Live.
We'll poke to author of framework to take a look at this.

Best regards,
Sebatian

Post Reply