Unresponsive interface

Share your experience, tips & tricks, show off your music. Wishes, ideas and feature suggestions
Post Reply
fishcorp
Posts: 6
Joined: Wed Mar 20, 2013 12:35 pm

Unresponsive interface

Post by fishcorp » Fri Jan 15, 2016 3:12 pm

Hi D16.

I've had some cases of the Decimort 2 interface becoming unresponsive .. possibly related to when i'm using automation. This is in Cubase 6.5 64bit on Win 8.1, nVidia Graphics ..

Can i help you debug this, provide you with logfiles or something?

Best,
Rune / FishCorp

User avatar
Sebastian@d16
Posts: 1524
Joined: Tue Nov 07, 2006 9:20 pm
Location: Katowice/Poland

Re: Unresponsive interface

Post by Sebastian@d16 » Mon Jan 18, 2016 2:56 pm

Hi Rune,

Thank you for reporting this. First of all, are you able to reproduce this when R and W automation flags are disabled at all? Also are you able to reproduce this with both R and W flags enabled ? (When automation is in read and touch-write state).

Cheers,
Sebastian

fishcorp
Posts: 6
Joined: Wed Mar 20, 2013 12:35 pm

Re: Unresponsive interface

Post by fishcorp » Thu Jan 21, 2016 4:13 pm

.. argh - i haven't had the time to sit down and do some methodic testing, but it's happend to me a number of times now; i'll hunt downt the bug down eventually. Just out of curiosity: are you using OpenGL in any way? I've noticed some strange interaction between Waves and FabFilter plugs which are both using OpenGL as GUI-backend ..

User avatar
Sebastian@d16
Posts: 1524
Joined: Tue Nov 07, 2006 9:20 pm
Location: Katowice/Poland

Re: Unresponsive interface

Post by Sebastian@d16 » Fri Jan 22, 2016 10:22 am

Hi,

Our graphics is raster based and we utilize JUCE framework for all our plug-ins, which on Windows uses Direct X 2D planes and on Mac OS X uses Cocoa for drawing UI.

Kind regards,
Sebastian

Post Reply