64bit VST2.4 plugins - GUI problems in 64bit Reaper on Mac

Share your experience, tips & tricks, show off your music. Wishes, ideas and feature suggestions
Post Reply
mustgroove

64bit VST2.4 plugins - GUI problems in 64bit Reaper on Mac

Post by mustgroove » Mon Mar 11, 2013 12:39 pm

This problem exists with all the D16 plugins, not just Devastor, but I'm posting it here because there is no "General" forum.

The 64bit VST2.4 D16 plugins all have big GUI issues in Reaper 64bit for Mac. When a plugin instance is created and the GUI is opened, the problems displayed by the plugins include:

- preset browser button, previous & next preset buttons do not operate when clicked
- manipulating knobs does nothing
- some GUIs don't draw properly at all

Hopefully you can address these issues.

My system:

Mac Pro (Mid-2010)
OS X 10.8.2
Reaper 4.32 64bit

User avatar
Sebastian@d16
Posts: 1524
Joined: Tue Nov 07, 2006 9:20 pm
Location: Katowice/Poland

Re: 64bit VST2.4 plugins - GUI problems in 64bit Reaper on Mac

Post by Sebastian@d16 » Tue Mar 12, 2013 11:41 am

Hi,

We confirm that's general issue of whole our software line (not only SilverLine collection plug-ins) under 64bit Reaper using 64bit VSTs. Options, Next, Prev and Browser button doesn't work. I'm adding this issue to our ToDo list right away and we're going to investigate it insightfully, find the source of the problem and fix this as soon as possible. For the time being i recommend you using 32bit version of Reaper (if you don't need to use more than 3.5 gigs of ram) under which our plug-ins work fine.

Best regards,
Sebastian

mustgroove

Re: 64bit VST2.4 plugins - GUI problems in 64bit Reaper on Mac

Post by mustgroove » Tue Mar 19, 2013 12:07 pm

Thanks heaps, looking forward to the fix!

Post Reply