Decimort 2 not saving settings

Share your experience, tips & tricks, show off your music. Wishes, ideas and feature suggestions

Decimort 2 not saving settings

Postby tappazee » Mon Jun 05, 2017 9:22 am

Hi - first off, fantastic plugin!

I'm using Logic X on Sierra and having the following issue: I save my Decimort settings as a preset in the dropdown menu in the top left of the Logic plugin window, but when I close a project and re-open it, Decimort 2 often (perhaps always) resets to an 'Init' patch so I have to find and select the correct preset every time I open the project in whatever instances of the plugin I have open. I don't have this problem with any other plugins.

Any ideas?

Thanks
tappazee
 
Posts: 2
Joined: Thu Jun 01, 2017 7:47 pm

Re: Decimort 2 not saving settings

Postby Sebastian@d16 » Thu Jun 08, 2017 9:19 am

Hi Tappazee,

Thank you for reporting the issue. I'm having trouble with reproducing it using our equipment I'm afraid, which is crucial in order to fix it. So I have few questions regarding your setup and circumstances in which the issue occurs:

1) What exactly version number of Logic X do you use?
2) What's version number of Decimort 2?
3) What's version number of your Mac OS (precisely, to know what updates have been installed)?

I'm having some troubles with understanding the circumstances, so:

4) Is the saving as Logic preset necessary step to make this issue happen or is this just problem with recalling an instance's parameter values when the project is reloaded?
5) Are you able to reproduce this problem using fresh, newly created project with just one instance of Decimort 2 there?

Thank you,

Cheers,
Sebastian
User avatar
Sebastian@d16
 
Posts: 1492
Joined: Tue Nov 07, 2006 9:20 pm
Location: Katowice/Poland

Re: Decimort 2 not saving settings

Postby Sebastian@d16 » Fri Jun 09, 2017 11:25 am

Hi,

Just wanted to let you know this may be a bigger issue that we though and concerns all the products from the recent update (Repeater, Antresol, Devastor 2 and Decimort 2). Problem is that it doesn't occur on all configurations and so far we were unable to reproduce it on our equipment, but we have some clues from the users' reports what may cause it, so right now we're investigating it and as soon as the bug will be fixed, the hotfix update shall be released.

Thank you,

Cheers,
Seb
User avatar
Sebastian@d16
 
Posts: 1492
Joined: Tue Nov 07, 2006 9:20 pm
Location: Katowice/Poland

Re: Decimort 2 not saving settings

Postby tappazee » Mon Jun 12, 2017 11:35 am

Hi thanks for this info. I'm not sure if my answers will help now it's been identified as a bigger issue, but here we go in case:

1) Logic X 10.3.1
2) Decimort 2.1.1
3) Sierra 10.12.5
4) Yes I think so
5) I just loaded up Logic with one single audio track with just decimort on and saved the settings. I restarted Logic three times and did not have the problem at all.

Hope this helps.

Cheers, Chris
tappazee
 
Posts: 2
Joined: Thu Jun 01, 2017 7:47 pm

Re: Decimort 2 not saving settings

Postby Sebastian@d16 » Fri Jun 16, 2017 11:25 am

Hi tappazee,

You're welcome and thank you for your setup details. We have a potential hotfix for the issue it seems. It's currently being tested by a beta team assembled of all users who reported this issue (via helpdesk). First results are promising and we potentially may release update in few days.

The thing is this issue happens in non-deterministic manner and we don't entirely know what's exactly the trigger for this problem to occur. We worked sort of blindfolded during investigation and right now we're gathering reports from the test team. If all of them will be positive, we have an official patch then.

Kind regards,
Sebastian
User avatar
Sebastian@d16
 
Posts: 1492
Joined: Tue Nov 07, 2006 9:20 pm
Location: Katowice/Poland


Return to DECIMORT 2

Who is online

Users browsing this forum: No registered users and 1 guest